Returns the ElementId of the (top-level) linked model with the given
ExternalResourceReference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static ElementId GetTopLevelLink( Document document, ExternalResourceReference reference ) |
Visual Basic |
---|
Public Shared Function GetTopLevelLink ( _ document As Document, _ reference As ExternalResourceReference _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ GetTopLevelLink( Document^ document, ExternalResourceReference^ reference ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to look for the linked model in.
- reference
- Type: Autodesk.Revit.DB..::..ExternalResourceReference
An ExternalResourceReference indicating which linked model to return.
Return Value
The id of the link with the given ExternalResourceReference, or InvalidElementId if there is no top-level link at that location.
Remarks
This function will not return nested links.
Revit will not check the version when checking for resource equality.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |