Gets the structural section from element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public StructuralSection GetStructuralSection() |
Visual Basic |
---|
Public Function GetStructuralSection As StructuralSection |
Visual C++ |
---|
public: StructuralSection^ GetStructuralSection() |
Return Value
The structural section. nullNothingnullptra null reference (Nothing in Visual Basic) if the family symbol does not contain a structural section.
Remarks
Only beams, braces and structural columns can have a structural section.
To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.