The ID of the parameter displayed by the field.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ElementId ParameterId { get; set; } |
Visual Basic |
---|
Public Property ParameterId As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ ParameterId { ElementId^ get (); void set (ElementId^ value); } |
Field Value
The parameter ID, or InvalidElementId.
Remarks
Most non-calculated field types require a parameter ID.
The Count field doesn't have a parameter ID.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |