Sets the sketch plane and the curve for this CurveElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetSketchPlaneAndCurve( SketchPlane sketchPlane, Curve curve ) |
Visual Basic |
---|
Public Sub SetSketchPlaneAndCurve ( _ sketchPlane As SketchPlane, _ curve As Curve _ ) |
Visual C++ |
---|
public: void SetSketchPlaneAndCurve( SketchPlane^ sketchPlane, Curve^ curve ) |
Parameters
- sketchPlane
- Type: Autodesk.Revit.DB..::..SketchPlane
The new sketch plane.
- curve
- Type: Autodesk.Revit.DB..::..Curve
The new curve.
Remarks
Unlike the setters of SketchPlane and GeometryCurve,
this method will reset relationships between the two properties and with other elements.
To set a geometry curve which belongs to a sketch-based elements, use GeometryCurve
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or -- Thrown if the sketch plane is set on a DetailCurve. -- or -- Thrown if the sketch plane is not suitable. -- or -- Thrown if the CurveElement belongs to a sketch-based element. -- or -- Thrown if modifying the sketch plane is not allowed. -- or -- Thrown if the CurveElement cannot be moved out of its sketch plane. -- or -- Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve. |