Removes a row data at a specified index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public void RemoveRow(
int nIndex
) |
Visual Basic |
---|
Public Sub RemoveRow ( _
nIndex As Integer _
) |
Visual C++ |
---|
public:
void RemoveRow(
int nIndex
) |
Parameters
- nIndex
- Type: System..::..Int32
An integer index.
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentException |
The row can't be removed because it's an element in linked file, default zone
or it's a row in body section of Material Quantity Take Off Schedule
or it's the last row in header section of standard schedule
or nIndex is invalid index.
|
See Also