Retrieves the profile loop used for the specified structural deck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementId GetDeckProfileId(
int layerIdx
) |
Visual Basic |
---|
Public Function GetDeckProfileId ( _
layerIdx As Integer _
) As ElementId |
Visual C++ |
---|
public:
ElementId^ GetDeckProfileId(
int layerIdx
) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
Return Value
The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer,
or invalidElementId if isStructuralDeck(layerIdx) is false.
Exceptions
See Also