FamilySymbol of the annotation to use for this connection type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetFamilySymbolId( ElementId familySymbolId ) |
Visual Basic |
---|
Public Sub SetFamilySymbolId ( _ familySymbolId As ElementId _ ) |
Visual C++ |
---|
public: void SetFamilySymbolId( ElementId^ familySymbolId ) |
Parameters
- familySymbolId
- Type: Autodesk.Revit.DB..::..ElementId
Remarks
The FamilySymbol must be of category "Connection Symbols"
(OST_StructConnectionSymbols) and have its "Apply
To" parameter set to match the applyTo property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to this type's applyTo property. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |