Returns the index of the nearest non-zero width layer before this layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public int GetPreviousNonZeroLayerIndex( int thisIdx ) |
Visual Basic |
---|
Public Function GetPreviousNonZeroLayerIndex ( _ thisIdx As Integer _ ) As Integer |
Visual C++ |
---|
public: int GetPreviousNonZeroLayerIndex( int thisIdx ) |
Parameters
- thisIdx
- Type: System..::..Int32
The layer from which to look for a non-zero width layer.
Return Value
The index of the layer found.
Remarks
If this layer is non-zero width, it will be returned. If there are non-zero width layers found, returns -1.