Adds a performance adviser rule to the list of rules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void AddRule( PerformanceAdviserRuleId id, IPerformanceAdviserRule rule ) |
Visual Basic |
---|
Public Sub AddRule ( _ id As PerformanceAdviserRuleId, _ rule As IPerformanceAdviserRule _ ) |
Visual C++ |
---|
public: void AddRule( PerformanceAdviserRuleId^ id, IPerformanceAdviserRule^ rule ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
- rule
- Type: Autodesk.Revit.DB..::..IPerformanceAdviserRule
The rule to be added
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |