Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsAllowedDimensionStyleType( DimensionStyleType dimensionStyleType ) |
Visual Basic |
---|
Public Function IsAllowedDimensionStyleType ( _ dimensionStyleType As DimensionStyleType _ ) As Boolean |
Visual C++ |
---|
public: bool IsAllowedDimensionStyleType( DimensionStyleType dimensionStyleType ) |
Parameters
- dimensionStyleType
- Type: Autodesk.Revit.DB..::..DimensionStyleType
The dimension style type to test.
Return Value
True if the type is allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |