Gets the user-visible name for a unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static string GetLabelForUnit( ForgeTypeId unitTypeId ) |
Visual Basic |
---|
Public Shared Function GetLabelForUnit ( _ unitTypeId As ForgeTypeId _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelForUnit( ForgeTypeId^ unitTypeId ) |
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Cannot find DisplayUnitTypeInfo for the given unit identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |