Get the Family of this Family Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic
Public ReadOnly Property OwnerFamily As Family
	Get
Visual C++
public:
property Family^ OwnerFamily {
	Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also