Override the SketchPlane property of CurveElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public override SketchPlane SketchPlane { get; set; } |
Visual Basic |
---|
Public Overrides Property SketchPlane As SketchPlane Get Set |
Visual C++ |
---|
public: virtual property SketchPlane^ SketchPlane { SketchPlane^ get () override; void set (SketchPlane^ value) override; } |
Remarks
CurveByPoints has no associated SketchPlane. Getting this
property returns nullNothingnullptra null reference (Nothing in Visual Basic). Setting it causes an InvalidOperationException.