Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static ExportDWGSettings GetActivePredefinedSettings( Document aDoc ) |
Visual Basic |
---|
Public Shared Function GetActivePredefinedSettings ( _ aDoc As Document _ ) As ExportDWGSettings |
Visual C++ |
---|
public: static ExportDWGSettings^ GetActivePredefinedSettings( Document^ aDoc ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve the active pre-defined exporting settings for DWG.
Return Value
The active pre-defined exporting settings for DWG, or null if nothing pre-defined exists or the in-session settings is selected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |