Checks that the parameters of the given ElementFilter (representing a combination of rules)
are valid for the given set of categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2019
Syntax
Visual Basic |
---|
Public Shared Function AllRuleParametersApplicable ( _
aDocument As Document, _
categories As ICollection(Of ElementId), _
elementFilter As ElementFilter _
) As Boolean |
Parameters
- aDocument
- Type: Autodesk.Revit.DB..::..Document
The document containing the filter, categories, and parameters involved in this validation.
- categories
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories against which to check the rule parameters.
- elementFilter
- Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter representing the combination of rules to check.
Return Value
True if all the parameters of the given rules are valid for this filter, otherwise false.
Exceptions
See Also