Returns the vectors describing the curve at the specified parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Transform ComputeDerivatives(
double parameter,
bool normalized
) |
Visual Basic |
---|
Public Function ComputeDerivatives ( _
parameter As Double, _
normalized As Boolean _
) As Transform |
Visual C++ |
---|
public:
Transform^ ComputeDerivatives(
double parameter,
bool normalized
) |
Parameters
- parameter
- Type: System..::..Double
The parameter to be evaluated.
- normalized
- Type: System..::..Boolean
If false, param is interpreted as natural parameterization of the curve.
If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
The transformation containing the point on the curve, the tangent vector, derivative of tangent vector, and bi-normal vector.
Remarks
Exceptions
See Also