Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public RevitLinkOptions(
	bool relative,
	WorksetConfiguration config
)
Visual Basic
Public Sub New ( _
	relative As Boolean, _
	config As WorksetConfiguration _
)
Visual C++
public:
RevitLinkOptions(
	bool relative, 
	WorksetConfiguration^ config
)

Parameters

relative
Type: System..::..Boolean
True if the link should use a relative path. False if it should use an absolute path.
config
Type: Autodesk.Revit.DB..::..WorksetConfiguration
A WorksetConfiguration object specifying the worksets to open when creating the link. Leave as nullNothingnullptra null reference (Nothing in Visual Basic) if the file is not workshared. Optionally, this may also be nullNothingnullptra null reference (Nothing in Visual Basic) for a workshared file, in which case Revit will open all worksets.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also