Creates and appends a new Non-Continuous Rail to the Rail Structure.
The new Non-Continuous Rail will have the given name, height and offset.
It will have default profile and material ElementIds.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2019
Syntax
Visual Basic |
---|
Public Function AddNonContinuousRail ( _
name As String, _
height As Double, _
offset As Double _
) As NonContinuousRailInfo |
Visual C++ |
---|
public:
NonContinuousRailInfo^ AddNonContinuousRail(
String^ name,
double height,
double offset
) |
Parameters
- name
- Type: System..::..String
The name of the non-continuous rail.
- height
- Type: System..::..Double
The height on which the non-continuous rail will be placed.
- offset
- Type: System..::..Double
The offset of the non-continuous rail from a [!:Autodesk::Revit::DB::Architecture::Railing] center.
Return Value
Handle to the new Non-Continuous Rail.
Exceptions
See Also