Creates a Reference from a Reference in an RVT Link.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public Reference CreateLinkReference( RevitLinkInstance revitLinkInstance ) |
Visual Basic |
---|
Public Function CreateLinkReference ( _ revitLinkInstance As RevitLinkInstance _ ) As Reference |
Visual C++ |
---|
public: Reference^ CreateLinkReference( RevitLinkInstance^ revitLinkInstance ) |
Parameters
- revitLinkInstance
- Type: Autodesk.Revit.DB..::..RevitLinkInstance
Id of the RevitLinkInstance that contains the reference.
Remarks
The reference that is returned can be used to create a family instance on a face in an RVT link.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when revitLinkInstance is nullNothingnullptra null reference (Nothing in Visual Basic). |