Returns the most recent numbered Revision shown on this ViewSheet.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ElementId GetCurrentRevision() |
Visual Basic |
---|
Public Function GetCurrentRevision As ElementId |
Visual C++ |
---|
public: ElementId^ GetCurrentRevision() |
Return Value
The Id of the most recent numbered Revision shown on this ViewSheet or InvalidElementId if none are shown.
Remarks
If the most recent Revision is not issued, Revit will typically use it as the default Revision for
RevisionClouds placed on this ViewSheet. InvalidElementId will be returned if no Revisions are present.
Revisions with RevisionNumberType.None will not be returned.