Adds a regular field at the specified position in the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ScheduleField InsertField( ScheduleFieldType fieldType, int index ) |
Visual Basic |
---|
Public Function InsertField ( _ fieldType As ScheduleFieldType, _ index As Integer _ ) As ScheduleField |
Visual C++ |
---|
public: ScheduleField^ InsertField( ScheduleFieldType fieldType, int index ) |
Parameters
- fieldType
- Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
- index
- Type: System..::..Int32
The index in the list of fields.
Return Value
The new field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration |