Increments the iterator to the next element passing the filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public virtual bool MoveNext() |
Visual Basic |
---|
Public Overridable Function MoveNext As Boolean |
Visual C++ |
---|
public:
virtual bool MoveNext() |
Return Value
True if there is another available element passing the filter in this iterator.
False if the iterator has completed all available elements.
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
The FilteredElementCollector that yielded this iterator has been reset by another operation.
No further iteration is permitted with this iterator.
-or-
The iterator cannot proceed due to changes made to the Element table in Revit's database (typically,
This can be the result of an Element deletion).
|
See Also