Creates a new LinePatternElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static LinePatternElement Create( Document document, LinePattern linePattern ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ linePattern As LinePattern _ ) As LinePatternElement |
Visual C++ |
---|
public: static LinePatternElement^ Create( Document^ document, LinePattern^ linePattern ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which to create the LinePatternElement.
- linePattern
- Type: Autodesk.Revit.DB..::..LinePattern
The LinePattern associated to the newly created LinePatternElement.
Return Value
The newly created LinePatternElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |