Identifies if a given bar in this rebar set is hidden in this view.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool IsBarHidden( View view, int barIndex ) |
Visual Basic |
---|
Public Function IsBarHidden ( _ view As View, _ barIndex As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool IsBarHidden( View^ view, int barIndex ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view.
- barIndex
- Type: System..::..Int32
The index of the bar from this rebar set.
Return Value
True if the bar is hidden in this view, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |