Splits the family instance element at a point on its defining curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementId Split( double param ) |
Visual Basic |
---|
Public Function Split ( _ param As Double _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ Split( double param ) |
Parameters
- param
- Type: System..::..Double
The normalized parameter value along the element (should be greater than 0 and less than 1).
Return Value
The newly created family instance id.
Remarks
Splitting is permitted for architectural and structural columns, beams and braces. Beams and braces that are not a line or an arc is not permitted. See CanSplit to determine if the family instance is allowed to be split by this method.
Splitting modifies this family instance and adds a second family instance to the model.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when parameter is out of range. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family instance element cannot be split. |