Create a symbolic curve in an Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public SymbolicCurve NewSymbolicCurve( Curve curve, SketchPlane sketchPlane ) |
Visual Basic |
---|
Public Function NewSymbolicCurve ( _ curve As Curve, _ sketchPlane As SketchPlane _ ) As SymbolicCurve |
Visual C++ |
---|
public: SymbolicCurve^ NewSymbolicCurve( Curve^ curve, SketchPlane^ sketchPlane ) |
Parameters
- curve
- Type: Autodesk.Revit.DB..::..Curve
The geometry curve of the newly created symbolic curve.
- sketchPlane
- Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the symbolic curve.
Return Value
The newly created symbolic curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed. |