Tests that the global parameter has data of a type that supports reporting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public bool HasValidTypeForReporting() |
Visual Basic |
---|
Public Function HasValidTypeForReporting As Boolean |
Visual C++ |
---|
public: bool HasValidTypeForReporting() |
Return Value
True if the parameter has data of a type that supports reporting; False otherwise.
Remarks
Only few data types can be used for reporting parmeters. Currently, reporting
global parameters must be either of type Lenght or Angle -
basically, they need to be value-driven by standard dimensions.