Check if property can be edited.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public bool IsEditable() |
Visual Basic |
---|
Public Function IsEditable As Boolean |
Visual C++ |
---|
public: bool IsEditable() |
Return Value
True if property is editable.
Remarks
Properties can be edited only if there is an active Edit Scope and if the property is allowed to be changed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The asset property is not editable. Asset can be edited only in an edit scope. |