Returns the boundary segments.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IList<IList<BoundarySegment>> GetBoundarySegments( SpatialElementBoundaryOptions options ) |
Visual Basic |
---|
Public Function GetBoundarySegments ( _ options As SpatialElementBoundaryOptions _ ) As IList(Of IList(Of BoundarySegment)) |
Visual C++ |
---|
public: IList<IList<BoundarySegment^>^>^ GetBoundarySegments( SpatialElementBoundaryOptions^ options ) |
Parameters
- options
- Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The SpatialElementBoundaryOptions.
Remarks
This method is used to retrieve the segments that constitute the boundary of the spatial element.
Each spatial element may have several regions, each of which have several segments hence the data is returned
in the form of an array of boundary segment arrays. See the BoundarySegment object for more
details about the segments that make up the spatial element topology.