Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied.
If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
Visual Basic |
---|
Public Sub SetShape ( _
pGeomArr As IList(Of GeometryObject) _
) |
Parameters
- pGeomArr
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape of this object expressed as a collection of GeometryObjects.
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
See Also