Creates a logical data object of the specified type.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static IFCData CreateLogicalOfType( IFCLogical value, string typeName ) |
Visual Basic |
---|
Public Shared Function CreateLogicalOfType ( _ value As IFCLogical, _ typeName As String _ ) As IFCData |
Visual C++ |
---|
public: static IFCData^ CreateLogicalOfType( IFCLogical value, String^ typeName ) |
Parameters
- value
- Type: Autodesk.Revit.DB.IFC..::..IFCLogical
The IFCLogical value.
- typeName
- Type: System..::..String
The type name.
Return Value
The IFCData object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |