The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic
Public Property Direction As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ Direction {
	XYZ^ get ();
	void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is not perpendicular to the normal vector.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException When setting this property: newDir has zero length.

See Also