Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarFreeFormValidationResult SetCurves( IList<CurveLoop> curves ) |
Visual Basic |
---|
Public Function SetCurves ( _ curves As IList(Of CurveLoop) _ ) As RebarFreeFormValidationResult |
Visual C++ |
---|
public: RebarFreeFormValidationResult SetCurves( IList<CurveLoop^>^ curves ) |
Parameters
- curves
- Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
Each curve loop represents a bar in the set.
Return Value
Returns Success if everything is ok, otherwise the failure reason.
Remarks
This function can fail due to following reasons:
- The array of CurveLoops is empty.
- At least one CurveLoop is empty.
- At least one CurveLoop contains an unbounded curve.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarFreeFormAccessor Rebar is constrained. |