Indicates if the given element is a detail element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static bool IsDetailElement( Document pDocument, View pDBView, ElementId detailElementId ) |
Visual Basic |
---|
Public Shared Function IsDetailElement ( _ pDocument As Document, _ pDBView As View, _ detailElementId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsDetailElement( Document^ pDocument, View^ pDBView, ElementId^ detailElementId ) |
Parameters
- pDocument
- Type: Autodesk.Revit.DB..::..Document
The document.
- pDBView
- Type: Autodesk.Revit.DB..::..View
The view.
- detailElementId
- Type: Autodesk.Revit.DB..::..ElementId
The detail elementId
Return Value
True if it is a detail element, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |