Evaluates a parameter on the polyline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public XYZ Evaluate( double param ) |
Visual Basic |
---|
Public Function Evaluate ( _ param As Double _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ Evaluate( double param ) |
Parameters
- param
- Type: System..::..Double
The parameter to be evaluated. It is expected to be in [0,1] interval mapped to the bounds of the whole polyline.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the param value is not between 0.0 and 1.0. |