Checks consistency of the Analytical Model.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool CheckAnalyticalConsistency( Document document ) |
Visual Basic |
---|
Public Shared Function CheckAnalyticalConsistency ( _ document As Document _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckAnalyticalConsistency( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
Document in which to perform consistency checks.
Return Value
True if run succeeded, false otherwise.
Remarks
Existence of inconsistencies will not affect the return value.
If inconsistencies are found, Revit will post warnings regarding those inconsistencies.
This should be run from within a transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |