The line shape of stairs path at the corner.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public StairsPathLineShapeAtCorner LineShapeAtCorner { get; set; } |
Visual Basic |
---|
Public Property LineShapeAtCorner As StairsPathLineShapeAtCorner Get Set |
Visual C++ |
---|
public: property StairsPathLineShapeAtCorner LineShapeAtCorner { StairsPathLineShapeAtCorner get (); void set (StairsPathLineShapeAtCorner value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Either the stairs path direction is not AutomaticUpDown, or it is AlwaysUp but DrawForEachRun is false. |