Constructor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public ConnectionValidationWarning( ConnectionResolution resolution, ConnectionWarning reason, ElementId part1, ElementId part2 ) |
Visual Basic |
---|
Public Sub New ( _ resolution As ConnectionResolution, _ reason As ConnectionWarning, _ part1 As ElementId, _ part2 As ElementId _ ) |
Visual C++ |
---|
public: ConnectionValidationWarning( ConnectionResolution resolution, ConnectionWarning reason, ElementId^ part1, ElementId^ part2 ) |
Parameters
- resolution
- Type: Autodesk.Revit.DB..::..ConnectionResolution
Resolution type.
- reason
- Type: Autodesk.Revit.DB..::..ConnectionWarning
Warning reason.
- part1
- Type: Autodesk.Revit.DB..::..ElementId
First element Id.
- part2
- Type: Autodesk.Revit.DB..::..ElementId
Second element Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |