Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public ElementId AsElementId(
	FamilyParameter familyParameter
)
Visual Basic
Public Function AsElementId ( _
	familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId^ AsElementId(
	FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException Thrown if the input argument-"familyParameter"-is invalid,

See Also