Add a pipe slope value.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void AddPipeSlope( double slope ) |
Visual Basic |
---|
Public Sub AddPipeSlope ( _ slope As Double _ ) |
Visual C++ |
---|
public: void AddPipeSlope( double slope ) |
Parameters
- slope
- Type: System..::..Double
The pipe slope value. Revit stores the slope value as a percentage (0-100).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for slope must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can not add a pipe slope value that was already added. |