Instantiates a transaction object
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Transaction(
Document document,
string name
) |
Visual Basic |
---|
Public Sub New ( _
document As Document, _
name As String _
) |
Visual C++ |
---|
public:
Transaction(
Document^ document,
String^ name
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document for which this transaction is going to be used.
- name
- Type: System..::..String
The name of the transaction. This name will appear in the undo menu
once the transaction is successfully committed. The name must not be empty.
The name can be reset later by either calling SetName(String) or
by using the name argument in the Start(String) method.
Remarks
Exceptions
See Also