Retrieves ElementId of Sketch Component, if such an operation makes sense.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public ElementId GetComponentElementId()
Visual Basic
Public Function GetComponentElementId As ElementId
Visual C++
public:
ElementId^ GetComponentElementId()

Return Value

ElementId of Sketch Component. If the operation does not make sense (perhaps because the Sketch abstraction does not translate one-to-one to ElementIds), then this will return invalidElementId.

See Also