The fully qualified path of the document's disk file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public string PathName { get; } |
Visual Basic |
---|
Public ReadOnly Property PathName As String Get |
Visual C++ |
---|
public: property String^ PathName { String^ get (); } |
Remarks
This string is empty if the project has not been saved
or does not have a disk file associated with it yet.
Note that the pathname will be empty if a document is detached. See IsDetached.
Examples

string docPathName = document.PathName;

Dim docPathName As String = document.PathName