Define a ReferencePoint relative to a Face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class PointOnFace : PointElementReference |
Visual Basic |
---|
Public Class PointOnFace _ Inherits PointElementReference |
Visual C++ |
---|
public ref class PointOnFace : public PointElementReference |
Remarks
A ReferencePoint on a Face has its X and Y
basis vectors parallel to the Face, but is free to rotate
around its Z basis vector. It must lie on the face
(unlike PointOnPlane).