Constructs a new instance of a File Open dialog.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public FileOpenDialog( string filter ) |
Visual Basic |
---|
Public Sub New ( _ filter As String _ ) |
Visual C++ |
---|
public: FileOpenDialog( String^ filter ) |
Parameters
- filter
- Type: System..::..String
The filter string. See the remarks for Filter for details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input filter string does not meet the minimal requirements for a valid filter string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |