Sets name and path information identifying systems analysis workflow files.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public void SetSystemsAnalysisWorkflows( IDictionary<string, string> paths ) |
Visual Basic |
---|
Public Sub SetSystemsAnalysisWorkflows ( _ paths As IDictionary(Of String, String) _ ) |
Visual C++ |
---|
public: void SetSystemsAnalysisWorkflows( IDictionary<String^, String^>^ paths ) |
Parameters
- paths
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of systems analysis workflows.
Remarks
The map should be specified as a key that is the name of the systems analysis workflow,
and a value that is the path to the workflow file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |