Gets a copy of the pattern info associated to the input pattern key.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ExportPatternInfo GetExportPatternInfo( ExportPatternKey exportPatternKey ) |
Visual Basic |
---|
Public Function GetExportPatternInfo ( _ exportPatternKey As ExportPatternKey _ ) As ExportPatternInfo |
Visual C++ |
---|
public: ExportPatternInfo^ GetExportPatternInfo( ExportPatternKey^ exportPatternKey ) |
Parameters
- exportPatternKey
- Type: Autodesk.Revit.DB..::..ExportPatternKey
The export pattern Key.
Return Value
Return the patternInfo for this key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |