Checks if the rod is locked with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public bool IsRodLockedWithHost(
	int rodIndex
)
Visual Basic
Public Function IsRodLockedWithHost ( _
	rodIndex As Integer _
) As Boolean
Visual C++
public:
bool IsRodLockedWithHost(
	int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The index of the rod.

Return Value

True if the rod is locked with its host.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException The hanger is not a bearer hanger.

See Also