Validates the formuls
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static string Validate( ElementId parameterId, Document document, string formula ) |
Visual Basic |
---|
Public Shared Function Validate ( _ parameterId As ElementId, _ document As Document, _ formula As String _ ) As String |
Visual C++ |
---|
public: static String^ Validate( ElementId^ parameterId, Document^ document, String^ formula ) |
Parameters
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
- document
- Type: Autodesk.Revit.DB..::..Document
- formula
- Type: System..::..String
Remarks
It validates formula using list of global or family parameters depends on document type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |