Indicates whether Analytical Alignment Method is valid for Sketch Component.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool IsValidAnalyticalAlignmentMethod( AnalyticalAlignmentMethod alignmentMethod ) |
Visual Basic |
---|
Public Function IsValidAnalyticalAlignmentMethod ( _ alignmentMethod As AnalyticalAlignmentMethod _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidAnalyticalAlignmentMethod( AnalyticalAlignmentMethod alignmentMethod ) |
Parameters
- alignmentMethod
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method preset to test for validity.
Return Value
True means alignment method is valid, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |